Amazon Captcha login


#1

I’ve just been presented with a Captcha when I try to log in to my Amazon account.

After 6 attempts I still couldn’t get in.

That was on Firefox. I switched to Chrome and got straight in with no Captcha asked for.

Anyone else having this problem?


#2

After the login page a new login page comes up with a captcha, which isn’t accepting any of my solutions.


#3

I now commonly get the ‘set up 2 step’ page after logging-in, but no captcha.


#4

That’s odd.

I’m using Firefox but haven’t seen that (as yet).

Does it come before or after the usual log-in page?

I’ve tried logging in to both these domains and didn’t see it:

https://sellercentral-europe.amazon.com

https://sellercentral.amazon.co.uk


#5

Still same problem this morning.


#6

It appears to be random, I’ve had it twice in the last 10 days. I use firefox and got in fine. Are you using the most up to date version of Firefox? Usually captcha gives you the chance to refresh it to get another new one to copy as sometimes I think they are totally unreadable, can’t tell which is upper and lower case for example.


#7

Still the same problem.

I’ve checked everything is up to date, disabled add-ons etc.

I can log in as normal of Android Firefox on my tablet, and on Chrome & IE on my PC, so it looks like only Firefox on my PC is affected.

I’m seeing a few more reports of the same problem on other forums, so it’s not just me.


#8

Is that regarding Amazon or Firefox generally?


#9

This specific problem.


#10

I have got the same problem, noticed it yesterday, but I have not tried to log in for a few days. Still the same today.
It is occurring on Linux (Suse) and Windows (my old Win2000 box!) both using Firefox. It is also doing it on Opera and SeaMonkey on Linux. Managed to login using Yandex, just tested on Chromium and that also seems to work


#11

Strange, I’ve never known Amazon to use captchas.

Is it possible you have some sort of Firefox addon that’s misbehaving?
[edit - Bardon’s post would seem to rule that out]

It would be nice to have some input from the mods.

Edited by: pudding’n’pie on Jun 14, 2017 3:13 PM


#12

When I tried to login today, I was presented with a new screen, it said I had been sent a code by email.
I immediately received a code, entered it and it worked.

Looks like there must have been a problem with captcha.

I sent a message to CS yesterday, but I just received a form reply to clear my cache & cookies.


closed #13